Yvanoph Karim Modérateur ABC du Web Karim Yvanoph WebMaster 3Alannet webmaster@abc-du-web.com BP 116 7080 Menzel JEMIL Gouvernorat de BIZERTE Tunisie Yvanoph www.abc-du-web.com 0021625332209
Retour à l'Accueil du Mode d'Emploi du Forum XWebDesignor ?
   Accueil   Aide Rechercher Tags Identifiez-vous Inscrivez-vous  
Pages: [1]   Bas de page
  Imprimer  
Auteur Fil de discussion: JSC Editor, l' HORREUR par une ERREUR, IMPENSABLE ? ? ?  (Lu 1522 fois)
yvanoph
Administrator
Hero Member
*****
Hors ligne Hors ligne

Messages: 2 818


Le PIRE des défauts, ne pas RECONNAÎTRE une erreur


Voir le profil WWW
« le: Mar. 03 Septembre 2013 à 23:11:26 »

UNE journée de PERDUE à cause d'un programme MAL FOUTU

Pour éviter les doublons inutiles de Code, tant en "<head>" qu'en "<body>", Admin a modifié XWebDesignor pour n'en conserver qu'un seul exemplaire, ce qui, à première vue, est fort bien ?
En "<head>" ça fonctionne sans souci, et pour cause, vous allez comprendre...


Soit un JSC, qui emploie donc une "<div>" crée par XWD, donc Case "[Comportement/N'emploie pas une (div)]" NON cochée !

Et là dedans vous mettez :

<div id=" .../...
   <script type .../... src="A.js .../...
   <script type .../... src="B.js .../...
   <script type .../... src="C.js .../...
</div>

<div id=" .../...
   <script type .../... src="A.js .../...
   <script type .../... src="C.js .../...
</div>

<div id=" .../...
   <script type .../... src="B.js .../...
   <script type .../... src="C.js .../...
</div>


Il est donc évident qu'il y a des "<script>" identiques ? Donc autant ne les charger qu'une fois, pas davantage ! ! !


MAIS, le problème est que XWebDesignor supprime TOUT ce qui suit les doublons ! ! !
Et nous en arrivons à :

<div id=" .../...
   <script type .../... src="A.js .../...
   <script type .../... src="B.js .../...
   <script type .../... src="C.js .../...
</div>

<div id=" .../... ? ? ?

<div id=" .../...
? ? ?

Vous imaginez bien qu'ensuite, attendu que le contenu a disparu, il y a peu de chance que ça fonctionne ? Quant aux erreurs W3C parce que X "<div>" ne sont pas refermées... Et c'est d'ailleurs ce qui m'a permis de découvrir le pot aux roses ! Comme quoi d'être "pénible/chiant/maniaque", ça SERT depuis le temps que je le dépanne avec SON programme ? Liste NON exhaustive...

Car mes "<scripts>" généraient théoriquement du Code, dans des "<div>" vides, mais remplies par un "document.getElementById", mais quand lesdites "<div>" sont gommées du Code...
Et, en toute franchise, j'ai remis en doute TOUS mes programmes, et non XWD, avant de découvrir que c'est ce programme LE fautif ?
Car les éléments manquants rajoutés par FTP manuellement, ça a fonctionné DE SUITE ! ! !


Bon, ALORS, j'ai contourné ce défaut INADMISSIBLE en supprimant TOUS les "<scripts>" de mes JSCs, et les ai remplacé par des "addScript" en "appendChild" directement en "<body>", provisoirement ?

Car ça RAJOUTE du Code pour une erreur IMPARDONNABLE ! ! ! Pour un "PRO" qu'il dit, à mes yeux...


PAS cordialement, Yvanoph---

Journalisée

La théorie, c'est quand on sait tout mais qu'absolument rien ne fonctionne !

La pratique, c'est quand tout fonctionne "farpaitement" sans vraiment savoir pourquoi, ni d'ailleurs  chercher à comprendre...

Chance inouïe, ici théorie et pratique fonctionnent  !
Tags: JSC: Editor JSC JSCX 
Pages: [1]   Haut de page
  Imprimer  
 
Aller à:  

Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Soutenir Yvanoph par un Don ?
Boréal - V 1.0 by Yvanoph | Sitemap
XHTML 1.0 Transitionnel valide ! CSS valide !
Page générée en 0.128 secondes avec 21 requêtes.